1C. Перевод натурального числа из десятичной в шестнадцатиричную систему счисления

Необходимо организовать перевод из десятичной в шестнадцатиричную систему счисления. Пишем простую функцию для решения задачи

Решение

Читаем на Википедии статью о шестнадцатиричной системе счисления и пишем:

Функция ПеревестиЦелоеЧислоИз_10_В_16_СС(Знач Значение)

    Если Значение <= 0 Тогда
        Результат = "0";
    Иначе

        Значение = Цел(Значение);
        Результат = "";

        Пока Значение > 0 Цикл

            Результат = Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Значение%16 + 1, 1) + Результат;
            Значение = Цел(Значение/16);

        КонецЦикла;

    КонецЕсли;

    Если СтрДлина(Результат) < 2 Тогда
        Результат = "0" + Результат;
    КонецЕсли;

    Возврат Результат;

КонецФункции

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *